to DeskProto home page
Contact  
looking glass icon
to DeskProto Facebook page
to DeskProto Google Plus page
to DeskProto Youtube page

How to start without reading the manual.

Some DeskProto basics.

The function of this QUICK START text is to get you started without reading the manual. It is meant to explain the basic ideas of DeskProto, and you will need this information to be able to understand what is happening. Obviously it is better to use the Tutorial book: we advise to read and execute lessons one and two before you start making your own prototypes. Also try the instruction videos on this website for on-line instructions.

In addition DeskProto's Help menu offers valuable on-line help (and contains this quick-start help page as well).
Anyway, new users are advised to first use the DeskProto Wizard, that will guide them through all the steps needed to generate an NC toolpath file using their own geometry.


Screenshot of the complete DeskProto window
The DeskProto window, showing the free DpPictureFrame geometry (Tutorial lesson 1).

The DeskProto screen contains standard items like the title bar (top line), menu bar, toolbar (the row of buttons below the menu) and status bar (bottom line). The center area is divided into three tiles: the large View window on the right, and the windows Project Tree and NC files on the left. All these elements will be explained later on in this Tutorial.
You can always use the Help function for extra information on any part of the screen.

For now it is important to know that within this screen two different user-interfaces exist:
the wizard-based interface and the dialog-based interface.

The Wizard interface


The Basic 3D wizard, page 2
The Basic 3D wizard, page 5
Two pages of the Basic 3D wizard: page 2 What to machine, and page 5 Finishing.

New users are advised to use the DeskProto Wizards, that will guide them through all the steps needed to generate an NC toolpath file using their own geometry. The illustration above shows two typical wizard pages.
A wizard will set the same parameters as available in the dialogs, only now they are presented in a sequential series of screens, and only the most important parameters are available. You can find the wizards on the Start Screen or via the File menu.

The Dialog-based interface

When using the Dialog-based interface you need to know where to find the parameters. In this interface you can define parameters on three levels:

1. Project parameters include the name of the geometry file and the number of parts that you want to use to create this prototype.
2. Part parameters define What will be machined. These set size, orientation, position and alike.
Within each Part you can use one or more milling Operations.
3. Operation parameters define How the geometry will be machined.
These are in fact the only real "milling parameters". Three different types of operation are available: in addition to the standard (3D) Operation, a 2D Operation and a Bitmap Operation are available as well.

The Project is the central concept of DeskProto. All information about a prototype is stored in a Project file, which is the file to be opened when starting and to be saved when finishing. The project file contains all milling parameters and viewing parameters, and also contains a reference to the geometry file (although it does not contain the geometry itself).


Screenshot of the project tree window
A DeskProto Project Tree. This project contains one Part, with three Operations.

You can imagine the tree-like structure of a project, which is displayed in the Project Tree at the left side of the DeskProto screen: see the figure above. This sample Project Bottle consists of one Part called Half bottle and three Operations called Roughing, Finishing and Contour. Each operation line includes a lamp icon that you can switch on and off to make the operation (in)visible. The project will be named when saving it for the first time, until then the tree displays the name Untitled.

Note: to open a 3D file in DeskProto you must use "Load Geometry" in the File menu (if needed start a New project first). You cannot use OPEN, as you do not yet have a DeskProto project file for this new project. The 3D geometry is used for for Parts and for all 3D Operations.
This is different for 2D files and bitmap files, as these are used for one operation only. You can add such special operation in the Part parameters, or after right-clicking on the Part's line in the project tree:
To load a 2D file: create a 2D Operation and edit its 2D Operation parameters.
To load a Bitmap file: create a Bitmap Operation and edit its parameters.

The Menus

Any function in DeskProto can be reached using the pull-down menus (or using the buttons on the toolbar, or by double clicking in the Tree). The most important menus are described below:
  • The VIEW Menu offers the opportunity to change the way you look at the geometry. To reach the View commands in most cases you will use the buttons.
  • In the PARAMETERS Menu you can edit all geometry and milling parameters. For simple prototyping it is sufficient to edit only the Front Tab screen for both Part and Operation: the other Tabs can come later (all parameters have suitable default values).
  • The CREATE Menu is the most important; this is where you can start the milling calculations and write the NC program file.
Note: three different editions of DeskProto are available: Entry, Expert and Multi-axis. The Entry edition and the Expert edition contain subsets of the available Part and Operation parameters. For the rest the editions are equal.

The Examples

Do open the example project files that have been installed with the trial version. After loading the geometry a drawing will be created. Experiment with the thumb-wheels and with the mouse to rotate, zoom and pan. To calculate a toolpath use the CREATE-menu.

With the free trial version you can produce complete NC program files during a 30 day long trial period: sufficient to completely test whether DeskProto indeed works for your application and on your milling machine. In case of problems with the machine you can use the configurable postprocessor to solve them.