to DeskProto home page
Contact  
looking glass icon
to DeskProto Facebook page
to DeskProto Google Plus page
to DeskProto Youtube page

DeskProto FAQ

Frequently Asked Questions

The acronym FAQ is short for Frequently Asked Questions, and this is exactly what this list is. Of course including the answers to these questions. This will help you to directly solve a problem that you might have with DeskProto, without first having to wait for our reply to your email.

On this page: You can browse the list below, or as an alternative you can use the Search option of this website (also present at the top of each page) to find the information you need. The search also covers the FAQ.
Second source of information is the User Forum, which uses it's own search option.



1. Commercial questions about DeskProto.

How to buy, editions, prices, licenses, etc.


Goto top

2. General questions about DeskProto and Rapid Prototyping.



Goto top

3. File formats.



Goto top

4. Installation problems.



Goto top

5. Machines and postprocessors.



Goto top

6. Graphics problems when using DeskProto.



Goto top

7. Other problems when using DeskProto.



Goto top

8. Questions on how to use DeskProto.




Goto top

1. Commercial questions about DeskProto.

1.1 - How can I purchase DeskProto ? You can buy DeskProto either via one of our resellers worldwide (on the left select your continent),
or directly using our Webshop on the Order page of this website.

1.2 - Can I try DeskProto before I buy ? Yes, you can download a FREE trial version at the Download page of this website. This trial version is completely functional, for a period of 30 days. Extending the trial period is not possible.

1.3 - Do you charge an annual cost for software maintenance ? No, we don't. Buying DeskProto is a one-time purchase for a perpetual software license. We do not charge any annual cost for maintenance or support: you can use it as long as you like.
Bugfix updates (service releases) and Minor Updates are free of charge, see page Build History for update information. Email support is free as well, except for the lowcost hobby license. Support via the User Forum is free for all.
This being said, we also keep adding new features to DeskProto, and need to adapt it for newer versions of Windows. So you should expect that the perpetual license in practice still is limited: at a certain moment your old DeskProto can no longer be used on a fresh Windows version (for instance DeskProto V4 will not start on Windows 7). Major Updates are not free, though existing users can update to a new version at special Update prices

1.4 - How long does it take to get my software after I place an order ? Each order needs to be processed manually, which will take some time. In many cases delivery will be the next day, however in case of vacations and/or trade shows it may take longer. That is why the webshop after a successful order immediately will email you an unlocking code for 14 more trial days, allowing you to start using DeskProto immediately.

1.5 - How do I compare the three editions of DeskProto ? You can find a list of all supported features per edition in the Comparison table.

1.6 - Is there a discount if I upgrade to a more powerful edition of DeskProto ?
Yes, you can start with a lowcost license and then upgrade later. See the list of special Update prices.

1.7 - What are the differences between the three license types of DeskProto ?
Three types of license are available: Commercial, Educational and Hobby licenses. The functionality of the program is identical for all licenses, the difference is in the license conditions.
Educational licenses and Hobby licenses may not be used for any commercial applications.
Buying an educational license only is possible for schools, students and teachers (proof required).
Hobby licenses are not sold to companies, and for hobby licenses no free support is given.
Hobby licenses and educational licenses are available ONLY for the Multi-Axis edition.

1.8 - Is it allowed to install DeskProto on more than one computer ?
Yes, you are welcome to install your DeskProto on two computers - as long as you do not use these two copies at the same time. Many of our clients install a copy of their DeskProto software on their CAD computer and one on the PC or laptop in the workshop.

1.9 - Can you supply a turnkey system, including a CNC milling machine ?
Yes we can and most of our dealers can so as well. Do look at the Resellers page of this website: for every dealer (and for Delft Spline Systems as well) you will find a link to their website, showing which machines are available.


Goto top

2. General questions about DeskProto and Rapid Prototyping.

2.1 - I know nothing about machining: can I use DeskProto ?
Yes, you can: DeskProto has been especially developed to be used by products designers, jewelers, artists, medics, etc. So you do not need to be a CAM specialists to use DeskProto (though of course for the last group easy-to-use is an advantage as well). The DeskProto motto is "3D CNC machining for non-machinists".

2.2 - Currently we are using CAD software package "XXX": can this be combined with DeskProto ?
Yes, you can: any current 3D CAD system can export STL files. DeskProto can process 2D files as well (DXF and AI), however the 2D functionality is limited.
Even without any CAD system you can still use DeskProto by loading a bitmap file (any JPG, GIF or BMP) and making DeskProto convert that to a 3D relief.

2.3 - I thought that Rapid Prototyping was about stacking thin layers of material: how can DeskProto that uses CNC milling be called Rapid Prototyping ?
Some people indeed do define Rapid Prototyping as a technology to produce prototypes by adding material (Additive RP), which does exclude CNC milling as there material is removed (Subtractive RP). However, in our opinion this definition is incorrect: Rapid Prototyping is about creating a physical prototype: (1) from 3D CAD data, (2) Rapidly and (3) Automatically. The actual process used does not matter and will be a kind of black-box to the designer.
So in our view SRP as offered by DeskProto is a valid RP process.

2.4 - How does Rapid Prototyping using DeskProto compare to Stereolithography and other Layered Manufacturing Technologies (LMT) ?
Both available Rapid Prototyping methods, LMT and CNC have their specific advantages and disadvantages. As a result both have their preferred application areas as well: for CNC these are Concept Models and Styling Block Models, for LMT Functioning Prototypes.
See the publication "CNC versus LMT" (PDF/ 426 Kb) on the articles page of our website.

2.5 - I heard that DeskProto is not suited for high accuracy projects: is that correct ?
Indeed DeskProto has some limitations in accuracy:
- first is the STL file: all geometry is represented as a series of flat triangle surfaces. So a cylinder will not be a true cylinder, but a polygon instead. Still in any CAD system you can define the required accuracy in the STL export settings.
- second is the calculation algorithm: DeskProto projects a toolpath pattern onto the geometry. The XY positions of these paths are fixed, DeskProto calculates the Z-value for each XY. This means that the distance between the toolpaths sets a tolerance. For instance with a toolpath distance of 1 mm a cube of 10.5 mm cannot be made: it will either be 10 or 11 (DeskProto will make it 11). This is why DeskProto calls the Path-distance 'Precision': this distance sets the precision.
So it depends on what you need:
for machining a piston and a cylinder which need to perfectly fit DeskProto is not the right tool; also not for two curved closing surfaces in a mold that need to perfectly match.
For many other jobs DeskProto is perfect. You can do very accurate jobs, see for instance the ring pictures at the end of the Jewelry video page. Molds with flat parting surfaces are OK as well.


Goto top

3. File formats.

3.1 - Can DeskProto import all STL files ?
Yes: DeskProto understands the complete STL definition, both the binary and the ASCII format.
STL stands for STereo Lithography (sometimes also explained as Standard Triangle Language). Stereolithography was the first additive RP system. It's supplier defined the STL file, and luckily all other RP suppliers followed that definition. The file describes the outer surface of a part as a very large quantity of triangles.

3.2 - Can DeskProto import invalid STL files ?
Yes: where Additive RP systems need a true solid geometry, DeskProto accepts incomplete solids as well. So small defects like gaps, cracks, orphan surfaces etc are no problem: as long as the gaps are so small that the cutter cannot make a visible hole.

3.3 - Can DeskProto import DXF files ?
Yes, but not all, as DeskProto only understands a subset of the DXF format definition. DXF for instance can also contain a 2D drawing with dimension lines, which for DeskProto is useless information. DeskProto only can import the DXF entities 3D FACE and POLYFACE MESH (which are the same triangles as present in STL files). For instance all DXF files from 3D Studio are OK for DeskProto.
DXF stands for Drawing eXchange File, and is a file definition created by Autodesk for its AutoCad software. As many other suppliers followed that definition it is now widely used. Some care is needed as Autodesk changes the DXF definition with every new version of Autocad.
The 2D Operation in DeskProto can read 2D DXF files, in that case also only a subset of the entities is supported (Line, polyline, circle, arc). For more information on 2D DXF see the extensive Forum issue on this subject.

3.4 - Can DeskProto import VRML files ?
Yes. Again not all, however now 'Almost all'. DeskProto accepts both VRML version 1 and 2, including hierarchy and transformations. Only certain standard objects are not supported. Information on color, lighting and texturing is of course discarded. Do note that the standard file-extension for VRML files is .WRL
VRML stands for Virtual Reality Modeling Language, and has been created to use 3D geometry in an Internet web environment, along with HTML files.

3.5 - Can DeskProto import IGES files ?
No, IGES files can not be used with DeskProto. Reason is that the IGES format is far more complex than STL, which typically will result in conversion problems. Geometry conversion from system X to system Y using IGES files in many cases will lead to incorrect results. STL on the other hand guarantees smooth conversions. IGES is in fact only needed in case the geometry must be remodeled in the second system; for "downstream processes" like prototyping and moldmaking STL is fine. Do note that theoretically speaking using IGES results in a better surface quality (as the real surfaces are transferred, not a polygon approximation). In practice there is no difference, as in any CAD system the accuracy of the STL file can be freely chosen.
IGES stands for Initial Graphic Exchange Standard. It is an official standard, defined by an international committee of specialists. It can describe a wide variety of 2D and 3D entities.

3.6 - Can DeskProto import EPS and/or AI files ?
Yes, but not all, as DeskProto only understands a subset of the EPS/AI format definition. For more information see the extensive Forum issue on this subject
EPS stands for Encapsulated PostScript, AI stand for Adobe Illustrator. Both are proprietary format, subject to changes by Adobe.

3.7 - I cannot open my 3D geometry file: how can I find it in DeskProto ?
In DeskProto the Open button and Open command enable you to open a DeskProto Project file (DPJ), which does contain all settings for an existing project. In case you start with a fresh geometry, you need a NEW project, in which you can import your geometry using the 'Load Geometry' button or command.

3.8 - I cannot open my 2D drawing file: how can I find it in DeskProto ?
As DeskProto is mainly aimed at 3D, 2D is a bit hidden. You have to first add a 2D Operation (in Edit Part Parameters) and then edit the 2D Operation Parameters. One of these is the 2D file to be used: Browse to open the file that you need.
An easier alternative is to use the 2D Wizard.

3.9 - I cannot open my bitmap file: how can I find it in DeskProto ?
As DeskProto is mainly aimed at 3D, the bitmap application is a bit hidden. You have to first add a Bitmap Operation (in Edit Part Parameters) and then edit the Bitmap Operation Parameters. One of these is the Bitmap file to be used: Browse to open the file that you need.
An easier alternative is to use the Bitmap Wizard.

3.10 - DeskProto V6.0 does not recognize cutters when opening a V6.1 project file.
In DeskProto V6.1 we have changed the 'encoding' of all text strings. DeskProto V6.0 and older use ANSI encoding, which is OK for western languages but will give problems with non-western scripts like used in Chinese and Russian. DeskProto V6.1 uses Unicode (UTF), which is the current standard for encoding, and supports all scripts (character sets).
So in V6.0 and older project files (*.DPJ) are ANSI encoded, in V6.1 and newer they are UTF encoded.
DeskProto V6.1 can read both types of DPJ file, however older versions cannot always correctly open the new UTF encoded files. A problem is present only when names (part name, operation name, cutter name) are used that contain special characters. Like for instance the ä in the German cutter name "Kugelfräser 6": V6.0 will see this as "Kugelfräser 6"
The solution is to use the "Save As" function when saving a project file in DeskProto V6.1 that needs to be opened in V6.0 (or older). In the Save As dialog you can select a file type in "Save as type", and one of the types is "DeskProto 6.0 project files (*.DPJ)". The new project file then can be read by the old DeskProto version.


Goto top

4. Installation problems on various Windows versions.

4.1 - I cannot install DeskProto on my Windows 95 / 98 / NT / ME / 2000 system.
DeskProto V 6 no longer supports these old (obsolete) versions of Windows. Sorry about that.

4.2 - How can I install the 64 bits build of DeskProto ?
That will be done for you automatically: the DeskProto Setup detects if the Windows on your PC is 32 bits or 64 bits, and will automatically install the 64 bits DeskProto build on a 64 bits system.

4.3 - My Chinese DeskProto does not display all Chinese Characters on my Windows PC.
The Chinese version of DeskProto V6.0 uses both Unicode and "Extended ANSI" to display Chinese characters. For Extended ANSI the correct table for that language must be used, which is a Windows setting. Important is that you need to select "Simplified Chinese", as the characters used in "Traditional Chinese" are different.
Here are the instructions to select the correct language:
Win XP:
Control Panel > Regional and Language Options > Tab Advanced > Select "Language for non-Unicode programs" and set "Chinese (PRC)"
In Win XP it is also needed to check option "Install files for East-Asian Languages", on Tab page Languages of this same dialog.
Win Vista:
Control Panel > Clock, Language and Region > Regional and Language Options > Tab Administrative > Button "Change system locale..." > Select and set "Chinese (Simplified, PRC)"
Win 7:
Control Panel > Clock, Language and Region > Region and Language > Tab Administrative > Button "Change system locale..." > Select and set "Chinese (Simplified, PRC)"
Win 8:
Control Panel > Clock, Language and Region > Region > Tab Administrative > Button "Change system locale..." > Select and set "Chinese (Simplified, PRC)"
BTW: Win 8 also allows you to completely change the language and make it a Chinese Windows (or any other language).
Newer versions of DeskProto (from V6.1) use only Unicode: for these versions this problem no longer is present.

4.4 - My DeskProto V6 refuses to start, after a successful installation.
Please check if you are running in compatibility mode: this is not permitted for DeskProto.
You can check this via Properties in the Context menu of DeskProto's desktop icon (cursor on the icon, right mouse-click and select Properties).

4.5 - Can I run my old DeskProto V... on a new Windows version ?
For old versions (V5 and older) that still use a dongle the dongle drivers on the old Setup CD may be to old. You can download a newer (this is relative: from 2007) driver setup program: SetupDrv.exe This program (by Microcosm Ltd) will install dongle drivers.
DeskProto V4 and older will have problems (that can be solved) on Windows Vista and Win 7. Problems can be expected with the graphics (the Aero interface needs to be switched off, using option "Disable Desktop Composition"; see I cannot see any picture on my screen), every user will need to have administrative rights, and Windows will annoy you with several UAC warnings that you need to confirm.
DeskProto V5 has solved the graphics problems just mentioned by automatically switching off the Aero feature in Win Vista and Win 7 when starting. Still the administrative rights are needed and the UAC warning will be present.
DeskProto V5 and older can NOT be used on Win 8, on Win 10 and newer !   Reason is that switching off the Aero interface no longer is possible in these versions.

4.6 - DeskProto refuses to start after upgrading my Windows version
After upgrading Windows on a PC, for instance from Win7 to Win8, or Win8 to Win8.1, Win.. to Win10, DeskProto will no longer start, giving an error that "Your installation of DeskProto seems to be corrupt".
This will happen after any Windows upgrade, as the copy protection software confuses this with copying to a different PC.
We found that this also happens after a major automatic update of Win10: Windows then will also change it's Product ID, which is the ID that the protection software uses for identification.
The solution is to reinstall the (trial) software.
Also see the FAQ issue on this error message and the forum issue on this subject.

4.7 - I cannot find the location of the DeskProto Sample files
DeskProto is installed including some nice sample geometries (STL files). All these files are stored in a folder called Samples. Unfortunately the location of this folder varies per DeskProto version and per Windows version.
In DeskProto V5 and older the Samples folder can be found in C:\Program Files\DeskProto 5.0\
In DeskProto V6 and newer the situation is more complicated:
Current Windows version forbid users to edit any files under \Program Files\, so this needed to be changed to the \ProgramData\ folder: a standard location in Windows meant for this type of files.
The actual location of this folder differs per Windows version:
In Windows XP this folder is called: C:\Documents and Settings\All Users\Application Data\
In Windows Vista, Win7/8/10 the folder is located in the root: C:\ProgramData\.
Unfortunately Microsoft has made this a hidden folder. You can make it visible in File Explorer ('My Computer'):
- in Win Vista: open Organize >> Folder and Search Options >> tab View and select the option 'Show hidden files and folders'
- in Win XP and Win7: open Tools >> Folder Options >> tab View and select the option 'Show hidden files, folders (and drives)'.
- in Win8 and Win10: check "Hidden items" in the View ribbon of File Explorer.
For an easier access: on the left side of each File Open dialog in DeskProto we added a link to this folder, called "DeskProto samples".

4.8 - I get error "Your installation of DeskProto seems to be corrupt".
When at program start the error message "Your installation of DeskProto seems to be corrupt" is given, it is not possible to run DeskProto. This will happen when the time and date settings on your PC have been changed: do not tamper with the time settings in your trial period !
However, this situation can also occur in three other situations:
1- You have upgraded your Windows to a higher version.
2- You are running a DeskProto V6 dated before November 2015. At that time we have corrected a serious bug that disabled the program in 2016 and later (our 'delayed Millennium bug').
3- You are running a DeskProto V6 dated before November 2016 with Windows 10. The Windows 10 automatic updates will change the Windows ProductID, causing this error. From Nov 2016 DeskProto no longer uses the ProductID.
The solution:
Re-install DeskProto: you need to again download and run the DeskProto V6.1 Trial version Setup in order to run the latest build (which will recognize your license).
Important is that this reinstall will also again install all original driver files (cutters, machines and postprocessors). So in case you changed any of these original drivers you can first copy these files to a safe location and restore them afterwards. Driver files that you added will not be affected.
For more information about where these files are stored see FAQ issue I cannot find the location of DeskProto's Driver files.

4.9 - I have bought a new PC: how can I transfer my DeskProto license.
You can simply download a fresh trial version onto your new PC and run the Setup. After installation you can register this DeskProto (so remove the trial limitation) using the Name/Code combination on your license.
Please uninstall DeskProto from the old PC before you sell or give it to a new user.

4.10 - I get warning "An unidentified program wants to access your computer".
This may happen when starting the DeskProto Setup on Windows Vista (when installing a DeskProto with Build date 2016-11-29 = Revision 6246 or newer). Reason is that this Setup uses a newer version of the SHA (Secure Hash Algorithm) to "sign" the .exe files: SHA-256 instead of the old SHA-1.
For Windows 10 this more secure SHA will soon become required, however unfortunately Windows Vista does not recognize it. As Win Vista is becoming very rare we will not fix this problem. In case you get this error when starting the DeskProto Setup you can safely choose "Allow" and proceed.

4.10 - What is the answer to the "Anti-robot question" on the download page?
The grey button directly below that question has the text "Email me the Download instructions", so the answer to the anti-robot question needs to be "Email". This same answer is valid for the download pages in other languages.
Sorry that we needed to make downloading complicated: a question like this is needed as otherwise the form is submitted many, many times a day by crawler robots.


Goto top

5. Machines and postprocessors.

5.1 - The CNC machine that we have/want to buy is not listed in DeskProto: what to do ?
When you can find a different machine from the same manufacturer (like model 123 while you have model 456) then you can best try that one: in most cases all models will run using the same type of NC files. If it works then you can copy the machine definition in the Library of machines (Options menu), and in the new copy enter the correct name, dimensions and speeds.
If not, then in DeskProto it is easy to add a machine: you can do so yourself in the Library of machines. A second step needed is choosing/creating the postprocessor for the machine. If already available just select it, if not you can create one in the Library of Postprocessors. The easiest is just to copy an existing postprocessor that is almost right and then to edit it. Most machines accept G-code variations: in that case start with a copy of the postprocessor "ISO plain G-codes" and change that until it runs OK.
Obviously in case you are new in CNC machining it will be unclear what to configure: so the easiest way is just to ask us for support: we are happy to create a machine definition and a postprocessor for you, without charging any cost.

5.2 - The CNC machine that we have is listed in DeskProto, but without the Rotation axis unit that we have. Can we change this ?
In DeskProto it is easy to change your machine definition: you can do so in the Library of machines (Options menu). Adding a Rotation axis can be done by checking the box "Has rotation-axis" in the Advanced machine settings. Do NOT check "A-values may exceed ..." unless you are sure about this. After pressing OK (twice) the rotation axis functionality will be available in DeskProto.

5.3 - On my machine the rotation axis is parallel to the Y-axis
In DeskProto the rotation axis always is parallel to X (called an A-axis), however on some machines it is parallel to Y (called a B-axis). This is not a standard option in DeskProto, still you can trick DeskProto to support such machine. See forum topic 176.
This fix will only change the resulting NC file: the DeskProto screen still will show a rotation axis parallel to X.

5.4 - I cannot change the postprocessor to be used.
In DeskProto it is indeed impossible to directly choose which postprocessor to use for a certain project. Selecting a postprocessor is a two-step process: first you have to edit a machine-definition (Options menu) to connect the postprocessor to a machine, then you have to select that machine (Parameters menu) to be used in your project.

5.5 - What in fact is a postprocessor ?
The postprocessor is the part of the software that, when writing the NC Program File, converts the toolpath information to the correct format that is needed for the selected machine. It is in fact the same as in Windows a printer driver, only in CNC machining the common name is postprocessor. Each printer comes with its own printer driver, and also for every machine an special postprocessor will be needed.
Note that an ISO standard for NC programs has been defined (G-codes), however in practice machines that run on 'standard' G-code each will require different NC files (small differences). Still the postprocessor called "ISO plain G-codes" is a good starting point for these machines.
You can create and edit postprocessors in the Library of Postprocessors (options menu).

5.6 - We have a five-axis CNC machine: can we use DeskProto ?
Yes, you can: since Version 6 DeskProto supports 5-axis machining, in the Multi-Axis edition.
The support is for indexed machining, so to machine the part from several sides. Each side is done using three-axis machining, with a part-rotation in-between these operations.
For more information see Lesson 7 of the Tutorial book and the Austin Healey video.

5.7 - I let DeskProto send the NC file to my machine, but nothing happens.
In most cases this is due to a misunderstanding about what DeskProto does. DeskProto generates an NC file with toolpath information. DeskProto does NOT control a milling machine: it can for instance not generate step and direction pulses over the parallel port. It also cannot set the machine's workpiece zero point. For this functionality Control Software is needed. See the article An Introduction to CAM Software on the articles page of our website.
DeskProto's option "Send NC program to machine" can be used only for certain machines that function without Control software (for instance Roland machines) or have it built in the machine's controller (industrial machines like Fanuc and Heidenhain). Still for the latter it is preferred to use the special communication software that came with the machine, as in most cases that contains error checking on all communications.

5.8 - The rotation axis (4th axis) is rotating far too slow / far too fast.
Feedrate for rotation axis toolpaths is a difficult issue.
In standard G-code the Feedrate is defined only in linear speed units (like mm/sec, inches/min, etc). The G-code definition does not include a rotation speed command. This means that the controller needs to calculate the correct rotation speed that is needed to reach the prescribed linear feedrate: the closer to the rotation axis, the higher the rotation speed that is needed.
Unfortunately this is a complicated calculation and many controllers do not conform to the ISO G-code specifications in this matter.
For an example see forum issue Rotation axis speed in Mach3.
A more elaborate discussion on this subject can be found on forum issue A axis feed rates.

5.9 - I cannot find the location of DeskProto's Driver files
DeskProto uses a file to define each machine, postprocessor and cutter. All these files are stored in a folder called Drivers. Unfortunately the location of this folder varies per DeskProto version and per Windows version.
In DeskProto V5 and older the Drivers folder can be found in C:\Program Files\DeskProto 5.0\
In DeskProto V6 and newer the situation is more complicated:
Current Windows version forbid users to edit any files under \Program Files\, so this needed to be changed to the \ProgramData\ folder: a standard location in Windows meant for this type of files.
The actual location of this folder differs per Windows version:
In Windows XP this folder is called: C:\Documents and Settings\All Users\Application Data\
In Windows Vista, Win7/8/10 the folder is located in the root: C:\ProgramData\.
Unfortunately Microsoft has made this a hidden folder. You can make it visible in File Explorer ('My Computer'):
- in Win Vista: open Organize >> Folder and Search Options >> tab View and select the option 'Show hidden files and folders'
- in Win XP and Win7: open Tools >> Folder Options >> tab View and select the option 'Show hidden files, folders (and drives)'.
- in Win8 and Win10: check "Hidden items" in the View ribbon of File Explorer.


Goto top

6. Graphics problems when using DeskProto.

6.1 - The window to graphically edit segment or support is blank / black / transparent.
This may also happen when doing a Zoom Window on the main screen. In almost all cases the problem could be solved by downloading and installing the newest drivers for the graphics card.
Important is that using the button "Update Driver" in the Device Manager does not always find the latest driver ! We found this for a client using a laptop with onboard Intel HD graphics. The Inter Driver had build Build 8.15.10.2104 and Update Driver reported that this was up-to-date. Still the Intel DownloadCenter showed that the latest driver was Build 8.15.10.2622. Downloading and installing that driver solved the problem.
An issue with the "Intel Driver Update Utility" is discussed on Tips&Tricks page Display driver blues.
In case of graphics problems you can also try if changing the driver's settings will help: in most drivers it is possible to select from several options that balance performance and quality and several levels of hardware acceleration.
Finally, in the DeskProto preferences (tab page advanced) some graphics optimization settings can be changed, which also might do the trick.

6.2 - My computer screen shows strange behavior (invalid icons on buttons, 'textured' surfaces, etc).
We have heard this problem a few times, related to using other Open-GL based applications. The problem could always be solved by downloading and installing the newest drivers for the graphics card. Do note that the installation of some other OpenGL based application possibly can damage/overwrite a driver that did function correctly before.
It may also help to change the driver's settings for Hardware acceleration, see forum issue Graphics problems when using DeskProto.

6.3 - The graphic windows of DeskProto show strange behavior (missing or repeated lines).
This is an old DeskProto problem, that we could not reproduce nor fix until in Sept 06 we found a PC that showed the error. It should be solved in builds dated Sept 06 or newer.
The problem was related to the Vertical Synchronization of the display, and it could be solved by switching that Off: Open the Display Properties dialog, tab Settings, button Advanced, tab "Your graphics card". For NVidia GeForce: menu "Performance & Quality Settings", check "Show advanced Settings", Select "Vertical Sync", uncheck "Application controlled" and next select Off.

6.4 - The rendering on the screen shows red or black parts in the surface.
Red parts (V6) or black parts (V5 or older) in the rendering indicate that the backside of the surface is visible. Sometimes just one triangle is black, sometimes a larger part or even the complete geometry.
STL files contain information about which side of the surface is the outside and which is the inside of the object, so which side should be black. Obviously normally the inside is completely invisible, so it needs not be rendered and/or machined. In some cases this information is incorrect: the STL information marks invisible parts as being on the outside.
In DeskProto you can influence this with the option "Skip backfaces" in the Project Parameters dialog (parameter menu): see the help information at that point. You can experiment using the Teapot sample geometry, as there you can see the inside of the teapot half.
Do not confuse this with the brown surfaces that result from the option "Show downward faces": that option shows any undercuts (area where the cutter cannot reach).

6.5 - I cannot see any picture on my screen
After loading an STL file the geometry is not drawn on the screen. When I move my mouse it briefly flashes, not more.
This is a known problem for an older DeskProto version (V4 or older) running in Win Vista or Win 7: it is caused by the Aero interface combined with an Open GL drawing. It can be fixed by changing some display settings in Vista, see the description at the end of the forum page on this subject..
DeskProto V 5.0 automatically switches off the Aero interface at program start. In Version 6 of DeskProto (V 6.0) this is longer be needed as this version is fully compatible with the Aero interface.

6.6 - DeskProto complains about insufficient OpenGL capabilities of the graphics card (ATI/AMD cards only)
When installing a Windows driver for an AMD Graphics card (formerly ATI) you can choose between two versions:
1- the Catalyst Software Suite
2- the WDM Integrated Driver (preferred by Microsoft)
Here you need to select the Catalyst suite, as the WDM driver (Windows Driver Model) does not support OpenGL. Windows then will fall back on its old software renderer (OpenGL V1.0) to create the graphics, which misses some features and will make DeskProto very slow.
This same issue may come up after upgrading from Win8 to Win8.1: the upgrade will automatically install the wrong driver. You can select the correct driver in the Device Manager:
Expand the list of Display adapters, right-click on your display adaptor and select Update Driver. Select "Browse my computer for driver software", then "Let me pick from a list" and pick an OpenGL compatible version of the driver (not a type "WDDM" driver).

6.7 - On my hig-res screen (4K pixels) the DeskProto icons are too small to be recognized.
First please check the build date of your DeskProto: in Februari 2016 we have fixed a few issues with Windows text sizes above 100%. If needed download and install an update.
The icons still are too small though. Here we can only offer a workaround: use the Windows Magnifier to magnify the screen to 200%. You can pin the Magnifier to the taskbar to keep it available.
.

Goto top

7. Other problems when using DeskProto.

7.1 - After running DeskProto (V5 or older) in Windows 2000, I get an error message "The memory could not be read".
The full error message is "The instruction at '[address]' referenced memory at '[address]'. The memory could not be read. Click OK to terminate the program." This is a bug in Win 2000: see support.microsoft.com (Article ID: 262490). Can be solved by installing a free Win 2000 upgrade.

7.2 - DeskProto (V5 or older) refuses to recognize the dongle.
The dongle is needed to prevent illegal copies of the DeskProto software. Two types are available: for the parallel port (shipped until 2003) and for a USB port.
For a parallel dongle: by default the DeskProto Setup only installs the USB dongle drivers. In order to also install the parallel dongle driver:
- insert the DeskProto CD in the CD drive
- in the Run command (Start button) enter "E:\dongle\setupdrv.exe /par" (E: may be a different character on your PC). This will also install the parallel dongle driver.
For a USB dongle it may be needed to download and run a newer version of the dongle driver. You can download a newer (this is relative: 2007) driver setup program here: SetupDrv.exe.
You can find more about possible Dongle problems in the Reference manual (Version 5.0).

7.3 - I have inserted my USB dongle before installing DeskProto (V5 or older), and now the dongle is not recognized.
When inserting the dongle, the New-Hardware-Found Wizard starts searching for appropriate drivers. As DeskProto was not yet installed these were not yet present, so perhaps your Windows now uses incorrect drivers. You can check this in the Control Panel, System, at the Device Manager (for some Windows versions a Tab in this dialog, for others a button). The USB dongle is listed as "USB Security Key" under "Software Security Token". After opening the Properties for this device you can check and if needed change the drivers. Do not forget to reboot afterwards.
For more information see the Dongle troubleshooting section of the Reference manual (Version 5.0).

7.4 - My part is damaged when rotation axis machining on a Mach3 driven machine.
It seems like some of the rotation axis toolpaths are incorrect, though on the DeskProto screen all looks fine. This problem may be caused by an optimization setting in Mach3.
Please check dialog "General Logic Configuration" of the Mach 3 Software. On this (huge) page you can find a section "Rotational" with two checkboxes, called "Rot 360 rollover" and "Ang Short Rot on G0".
If one of these options is checked this may be the cause of the error.
Here is what the Mach3 manual says about these two options:
Rot 360 rollover: if checked, it will measure a rotary axis modulo 360 (0 to 360 then restart at 0). Otherwise, it will keep counting up (for example, two revolutions would be 720).
Ang Short Rot on G0: if checked, it makes any rotary axis treat the position given as an angle modulo 360 degrees. Moves will be by the shortest route to that position. For example, if the axis were at 0 degrees and a request was made to rotate to 359 degrees, it would rotate -1 instead of +359.

The Rollover option introduces an extra movement to A=0 for every A-movement, which may destroy your part (and will take very long).
The Ang Short option needs to be unchecked as well: rotating via the shorter route may destroy your part, as DeskProto checked only the route that was prescribed.

7.5 - When using the rotation axis, the part is a mirror image of the geometry.
The cause of this problem is that there is no clear standard for the rotation direction of the A-axis. Positive and negative directions are the same for X, Y and Z on all machines, unfortunately this is not the case for A. Some machines rotate right for a positive A value, others rotate left.
This can be fixed quite easily, in the DeskProto postprocessor:
Options menu >> Library of postprocessors >> OK on warning >> select your post and press Edit >> Movement tab >> put a minus sign in front of the value in field "Factor" of column (A).

7.6 - On my multi-core processor PC DeskProto uses only one of the cores.
In order for a program to use more than one core (or processor), 'multi-threading' is needed. The calculation then is divided into separate 'threads', each thread being assigned to one core. DeskProto supports multi-threading, however only in case more than one operation is present. Then it will create a separate thread for each calculation.
So in case of a PC with 8 cores, only a project that has 8 operations will be able to reach 100% CPU load. If it is critical then you can split up a 'heavy' operation, using subsegments to limit the area for each of the new operations.


Goto top

8. Questions on how to use DeskProto.

8.1 - I have chosen a different machine/cutter, however the resulting NC program file does not change.
In the past we have seen some users that tried to change the cutter or the machine using the Libraries in the Options menu. In that case nothing will change indeed, as the Options menu is only meant to change the machine- and cutter-definitions and the default settings. To indicate which of the machines/cutters must be applied, you have to use the Parameters menu. For the Machine the Part Parameters dialog, for the cutter the Operation Parameters dialog.

8.2 - I rotated the geometry, however the toolpaths appear to be for the original rotation.
DeskProto includes two different ways to rotate your geometry. One is for viewing only (mouse rotation, thumb-wheels, etc) which only influences the camera position, not the actual orientation of the geometry in space. The second is for 'real' rotations, and can be found in the Part Parameters. Do note the different behavior of the Orientator (the three axes in the left bottom corner of the screen): it does rotate when rotating the view, it does not rotate when rotating the part.

8.3 - I cannot influence the datum point (zero position) of my geometry.
We see two possible causes. The first is that you interpret the Orientator (the small cube with three axes in the left bottom corner of the screen) as an indication of the datum point (WorkPiece zero point). This is not true: it only indicates the direction of the axis system, so it will never move (only rotate). You can see the current position of the Workpiece zero point by checking the option "Orientator on workpiece zero point" in the Subjects in View dialog.
Secondly you might be confused by DeskProto's automatic translation: as a default DeskProto does translate you part, making the top-front-left corner of the bounding box (the material block) the workpiece zero point. This is OK for most cases, if not you can change the translation settings in the Part Parameters dialog (Translate tab page - not available in the Entry Edition).

8.4 - The workpiece zero point is different for operations with different cutters.
In most cases this is not an error but a misunderstanding instead. On the DeskProto screen you see two different black dots (V4) or downward red arrows (V5 or newer), one for each Operation. Each black dot / red arrow indicates the start of the toolpath, not the workpiece zero point. And indeed this first point may be different per operation: a thick cutter needs to move further outside of the part than a thin cutter. You can see the current position of the Workpiece zero point by checking the option "Orientator on workpiece zero point" in the Subjects in View dialog.
Still it may be that indeed an error is present: in some cases the control software performs an extra translation, shifting the zero to the extreme left-front tool position.
For instance the control software PCNC and WinPCNC: in the Parameters menu the command Misc... will lead to tab page Misc. parameters (in German "Sonstiges"). Here for Zero point in File ("Nullpunkt in Datei") the option Bottom ("Links unten") might be selected. This is NOT correct: it should be set to Origin of co-ordinates ("Koordinatenursprung"). Resetting this parameter is not all: unfortunately PCNC will restore this incorrect setting when opening an NC file that it has opened in the past. So when opening such NC file you need to use command "Open without parameters".

8.5 - I need a prototype that needs to be machined from all sides: how can I achieve this ?
As on a 3-axis milling machine the tool comes from one direction only (mostly from above, so from the positive Z-axis), you cannot machine the bottom of the part. Basically you have three options to create the complete model that you need:
1. you can machine two separate parts and attach them later (this is the easiest: see lesson 2 in the DeskProto Tutorial),
2. you can machine one block of material from two sides (use the Two Sided Milling Wizard - not available in the Entry Edition - or see lesson 3 in the Tutorial), or
3. you can use a Rotation axis device to rotate the part during machining (Multi-Axis edition only).

8.6 - How do I tell the machine where I fixtured the piece of material to be machined ?
This is in fact machine-dependant. Obviously the machine does not know where to start: you will have to tell by setting the workpiece zero point. DeskProto makes that easy by using the left-front-top corner of the material block as zero point. On most machines you can just move your tool to that position and tell the machine to use that position as workpiece zero point. Please consult your machines manual or your dealer for more help on this subject.

8.7 - I need both roughing and finishing toolpaths. How to achieve this ?
It is common practice to use a roughing operation first and then a finishing operation. Roughing means to remove excess material as quickly as possible, so using a large distance between the toolpaths and if possible a thick cutter. The finishing operation that follows uses a small toolpath distance for a smooth resulting surface.
In DeskProto this can be done by using two operations for the part (to create a second operation press Add operation or Copy operation in the Part parameters). The first operation is for roughing, the second for finishing: you can use appropriate names for clarity. In the Operation parameters for the Roughing operation you can use the options Skin and Layer height on the Roughing tab page. See the Help for more information. The Finishing operation will remove the remaining skin of material: small cutting forces for a smooth surface. For more information see the instruction video on Roughing and Finishing.
The easiest way to achieve this is by using one of the Wizards.
When the same cutter has been selected for both operations, the resulting toolpaths will be saved in one NC file, otherwise DeskProto will save two separate files. Unless of course your machine has an Automatic Tool Changer (ATC).

8.8 - I want to fine-tune the results of the (Two Sided Milling) Wizard. Is this possible ?
Yes, it is, and in fact we often do so as the wizard's settings are not optimal for every part. The changes that are needed most are:
- Adding operations. Run the wizard with the settings for the largest cutter (is needed to make your support blocks large enough). After finishing the wizard, create the finishing operation for each part, NOT by "Add operation", but instead by "Copy operation" (in the Part parameters). This is needed to copy all settings that the wizard made in the operation.
- Changing the cutting depth: when cutting a sphere the cutter does not need to go deeper than halfway down for each side. You can change the depth by editing the Z-min value of each Operation's subsegment.
- Editing the support blocks, as these are not always put at optimum locations. Note that DeskProto stores these blocks at Part level, so you will have to make the same changes twice: for both parts !
Note that the two-sided wizard is not available in the Entry Edition.