to DeskProto home page
Contact  
looking glass icon
to DeskProto Facebook page
to DeskProto Google Plus page
to DeskProto Youtube page

List of DeskProto releases, with included fixes.


Bugfree software does not exist, and also in DeskProto regularly bugs are found and corrected (feel free to report any bug that you find: we are happy with any feedback that will help us improve the program).
Regularly a new DeskProto build is made that contains a number of bugfixes: a Bugfix build, also known as Service Release.
Below you will find the revision history of DeskProto V 6.1: all builds that have been released, with a list of changes for that build.

DeskProto 6.1

All DeskProto builds show a Version number (like 6.1), a Build date and a Revision Number:
you can find these in the About box (Help menu) of your DeskProto program.
The version number changes only in case of any changes in the user-interface: in that case also different language-files for all translated versions are needed. Bugfix releases keep the same version number: they only have a different build date and revision number.

In case you need a newer build for your DeskProto V 6.1 (Entry/Expert/Multi-Axis) you can download and run the DeskProto V61 Updater (ca 10 MB): this special Setup that will update your DeskProto to the newest build (program file only, so without cutters, machines and postprocessors). The Updater can be used only on a PC with a complete DeskProto V 6.1 installed.

In case you want to upgrade from V6.0 to V6.1 then you need to download and install a fresh
DeskProto V6.1 Trial version. After that both V6.0 and V6.1 will be present on your PC.
Reinstalling the V6.1 trial version over an existing V6.1 will install fresh driver files (cutters, machines, postprocessors), help files etc, and thus will undo any changes that you have made.
In all cases your Registration information (license information) will remain valid.


Build date 2017-05-11   (Revision 6699) includes:
  • Major issue: once again a Win10 update caused an error: DeskProto refused to start.
    To fix this running the Updater Setup is sufficient. For details see the forum topic about this bug.
  • Before/After commands now are always written, regardless the status of "Write only if changed".
  • Some minor (text) changes.
  • New drivers, for the KinetiC-NC machine and controller.

Build date 2016-11-29   (Revision 6246) includes:
  • Major issue: Win10 updates caused error "Your installation seems to be corrupt".
    Since many years DeskProto has used the Windows ProductID to identify a machine. Unfortunately Windows 10 major automatic updates will change this ID, resulting in DeskProto reporting to be corrupt. This new build uses the ProcessorID instead.
    In order to fix this you need to again install the Trial version: running the Updater Setup is insufficient. See FAQ 4.8.
  • Selecting Sort, Meander ánd 'Skip hor ambient' could cause a gouging path in case of layers.
  • Estimate machining time did not apply machine setting "A-values may exceed 360".
  • Feedrates with decimal values could be rounded (decimal values removed).
  • Illegal facets (three equal points) in STL files now will be ignored when importing.
  • A fine grid of small triangles, exacly aligned with the toolpaths, could produce a bumpy surface.
  • DeskProto and its Installer now are signed using SHA-256 instead of SHA-1, see FAQ 4.10.
  • New driver, for the new Roland MDX-50.
  • Updated drivers for Shopbot machines and for Datron machines.

Build date 2016-6-6   (Revision 5828) includes:
  • "Always stay low" did not always work for toolpaths inside a cavity.
  • Print project data now also includes the "Number in machine" (ATC) for each cutter.
  • Contour-only toolpaths in a special case skipped a part of the geometry.
  • Fixed a crash when opening a DPJ file from a CD drive without disk.
  • The error 'Segment does not fit inside machine' could give wrong values for a bitmap operation.
  • New drivers for all ShopBot machines.
  • Various small textual improvements.

Build date 2016-2-19   (Revision 5664) includes:
  • The options to send the toolpaths or an NC file directly to the machine no longer worked (available only for a few machines). The error message also was very short: now more informative.
  • With the Windows text size set above 100%, in the wizards the buttons were not visible.
  • With the Windows text size set to 250% several texts became unreadable (project tree, combo-boxes, top lines of each wizard dialog). All text now is OK, only the images (icons) still are too small, to be fixed later. You can use Help to see the correct images.
  • The maximum size of the model in the custom wizard JWX30WaxModel was too small.
  • Setting a Plunge rate could result in superfluous extra points added to the NC program file.
  • The text "Use rotation axis" in the part parameters was not clear, as for indexed machining this option may not be selected. Is now "Use rotation axis (XZA paths)".
  • For Shapeoko (GRBL) DeskProto wrote NC files with extension .iso, has been changed to .nc
  • Added two machine definitions for Stepcraft machines with UNCNC controller.
  • The CAMaster Stinger definitions have been updated: dimensions, speeds, spindle command.
  • A few extra error checks on the status of OpenGL at program start have been added.
  • A few more small bugs have been corrected.

Build date 2015-11-20   (Revision 5531) includes:
  • Major issue: older builds of DeskProto V6.0 or V6.1 will refuse to start in 2016 or later !
    To correct this, users of DeskProto V6.1 need to run the V61 Updater, users of DeskProto V6.0 need to run the V61 Setup (the trial version, which will recognize your V6.0 license).
  • Ramping again works correctly for 2D Operations.
  • The 2D wizard did not ask whether or not to use Z-values when present in the DXF file.
  • The dialog "Set graphically..." in the Custom wizard Basic 3D milling did not open.
  • The dialog "Set graphically..." did not work correctly in bitmap operations.
  • Translucent drawings of Freeform segments were incorrect in case mirroring was applied.
  • Custom wizards now also work for non-standard default operations (see forum topic 411).
  • If "Use rotation axis" has been set as default, wizards now will switch it off (forum topic 401).
  • The "Export as..." commands now gives a warning when the file already exists.
  • The Japanese translation could not always find the correct default cutter.
  • The Setup can fix one more situation where the installation had been corrupted.
  • New machines: Shapeoke on GRBL, CAMaster Stinger, Stepcraft.
  • Various small bugs have been corrected.

Build date 2015-04-24   (Revision 5226) includes:
  • Just one fix, as in the build of April 22 a serious bug had been introduced:
    in the Part parameters it was no longer possible to change the Part segment.

Build date 2015-04-22   (Revision 5220) includes:
  • 2D DXF import now also reads Z-coordinates in entity LWPOLYLINE (if any).
  • Changing the bitmap dimensions did not immediately change the image on the screen.
  • All links in DeskProto updated to the new DeskProto website.
  • Button "Send to machine" in the wizards did not work (only applies to a few machines).
  • Removed a crash when zooming in the graphic edit support block dialog.
  • The freeform segment for a bitmap operation was not correct after opening a project.
  • In the wizards Rotary and 'Two or more sides' some of the Translation options did not work.
  • The wizards now no longer support loading two or more STL files.
  • Added a missing tooltip text in the Bitmap wizard.
  • The views layout was undefined for copied parts.
  • Improved the checks on the material block size in wizards Rotary and 'Two or more sides'.
  • The wizards would adjust default supports in case to short, this is now done for all supports.
  • The drawing to graphically edit a segment displayed an incorrect zero point.
  • After changing a support the information on the Segment tab was not updated.
  • Strategy Offset only offered 'Reduced feed rate for first movements', now 'Reduced feed rate for high chiploads' is supported.
  • Feedrates below 1 mm/sec were not possible, now they are.
  • Added machines and postprocessors: EAS Heavy 450, Roland SRM-20, Isel MiniFlat 40.

Build date 2014-10-28   (Revision 4819) includes:
  • An error about Z-values could be given when in fact no bitmap file was present.
  • The translation values in the Add geometry dialog were not correctly interpreted for inch users.
  • Options 'Use rotation axis' and 'Inverse milling' could both be active, which should not be possible.
  • Changing the Windows screen resolution could result in the Wizard being displayed 'off-screen'.
  • Empty command fields are no longer permitted in postprocessor options Tool Change and Rapid.
  • The Geometry Info dialog showed incorrect filetypes for STL (ASCII) and for VRML.
  • In the wizards it was possible to have two radio buttons selected for Orientation.
  • Exporting and Importing settings could result in a wrong value for the default bitmap DPI.
  • Contour-only toolpaths with a custom Ambient level and with Roughing layers went too low !
  • Saving an NC file could make DeskProto crash on a full disk (for instance USB stick too small).
  • A postprocessor for the NcStudio control software by Weihong (China) has been added.

Build date 2014-07-18   (Revision 4551) includes:
  • In Custom wizard 'JWX30 Wax Model' the setting for Skip Ambient was not correct.
  • The file-types for Export ZGrid were alphabetically sorted, causing errors in some translations.
  • Changing the language was not possible when in the default part only a 2D operation was present.
  • Opening the Default View dialog crashed when in the default part the first operation was 2D.
  • Pressing Cancel while loading a 2D file resulted in an error.
  • Strategy circular with different values for Path distance and Stepsize could cause gouging toolpaths.
  • The inch postprocessor for Mach3 wrote only 3 decimals for each coordinate value: now 4.
  • Wizard "Two or more sides, automatic rotation", did not process the translation setting (zero point).
  • DeskProto no longer remembered the last used Custom wizard.
  • The scripting function to set the border for 'X, left' did not work.
  • The scripting documentation was not correct for a number of support block functions.
  • Opening the "Start custom wizard" dialog from the Start screen could happen more than once.
  • Removing the first driver in one of the libraries (cutters, machines, postpr) was not possible.
  • 'Write NC program file' did not work after loading a project file with toolpaths.
  • Preference setting "Draw limited number of entities" was not always stored.
  • Checking "Display translated coordinates" for the Part segment and then changing a Translation setting caused errors.

Build date 2014-04-22   (Revision 4337) includes:
  • The Initial Personal Settings screen ("DeskProto welcome", asking for Machine and Units to be used) no longer appeared for first time users! This bug has remained undetected since the release of V6.1 :-(
  • When "Always stay low" is applied, now only the toolpaths inside the freeform segment are lowered.
  • The Free movement height is the distance above the top of the Operation subsegment. Only for the first/last point of a toolpath it is above the Part segment. This last detail no longer was correct.
  • For strategy Block, subsetting "Inside-Out" the Milling Direction (Climb/Conventional) was reversed.
  • The value for Border setting "Extra for cutter" was not correct in case of a Roughing skin.
  • For multiple-line Feedrate/Spindle commands (postproc using "^\N") the line numbers were incorrect.
  • The Skip Ambient settings were not correctly shown in Print Project Data (File menu).
  • The number of remaining Trial days now is displayed in red (on the trial screen).

Build date 2014-02-7   (Revision 4160) includes:
  • First point and last point of a toolpath could be below the Part's maximum Z:
       important fix : this could damage the part in case of multiple operations.
  • Mirroring did not include the Centre point for strategies Circular and Radial.
  • Repaired a crash (Access violation) in the circular toolpath calculations.
  • The warning when opening the cutter library is not needed when opening from the wizards.
  • The block sizes in the Report file (wizard "Two sides, manual flip") were incorrect.
  • The contour-only strategy did not always find all contours.
  • Unchecking "fill gaps" (strategy waterline) now removes all short paths. Also less positioning moves.
  • Same optimization bug (in the C++ compiler) as in Rev 3949, now also fixed in 32 bits builds.
  • The Help file text on positioning movements (Free movement height) was not correct.
  • The wizards did not show the correct layer height after selecting "Use cutting length of cutter".
  • Scaling in the wizards now can be defined with 5 decimals, just like in the Operation parameters.
  • When DeskProto cannot find a geometry file it now also searches the Samples folder.

Build date 2013-11-27   (Revision 3949) includes:
  • Circular and Spiral toolpath calculations with 'Also machine corners' checks could crash.
  • Operations with many roughing layers took long to calculate and could crash on insufficient memory.
  • Strategy Contour-only no longer started with the most inner contours: now it does.
  • An error could result in NC files containing the string "1.#IO" instead of a valid number.
  • The feed rate reduction for plunge movements did not work for strategies Contour and Waterlines.
  • Custom wizard "4-axis wax ring" gave an error on the operation segment.
  • Rotation axis toolpaths with A-values above 360 could insert a full rotation back to A=0.0
  • The wizards showed strange values when selecting "Dimensions" for scaling (64 bits build only).
  • An optimization option (inline function expansion) in the C++ compiler created errors in 64 bits builds.
  • Changing a support block could double the number of support blocks.
  • After changing an invisible operation the toolpaths were not automatically recalculated.
  • Postprocessors for Roland MDX-15/20 still created .mod files: now .prn files.
  • Function key F1 with the Tree view active failed to launch Help.
  • Toolpaths with the "Rotation axis tilt option" used were drawn incorrectly.
  • The red and green areas in a simulation were incorrectly positioned.
  • Custom values for the simulation's tolerance were not stored.
  • In the .bak file created after saving a .dpj all Capitals were replaced by lower case characters.

Build date 2013-10-09   (Revision 3801):
  • This is the first release build of DeskProto V 6.1



Goto top

DeskProto 6.0

For DeskProto V6.0 the Trial version setup and the Updater setup are no longer available.
Reason is a bug that makes it impossible to start the program in 2016 or later. For DeskProto V6.1 a Bugfix is available, for V6.0 it is not as all users of V6.0 can simply update to V6.1 (free of charge).


Build date 2013-07-08   (Revision 3571) includes:
  • In the Basic 3D wizard the supports were cut loose (the wizard did not set the Borders).
  • Toolpath calculations could crash for: Conic_cutter and Angle_with_X and Always_stay_low on.
A new build for only two fixes, because the supports bug was a very serious one, confusing new users (see the reporting of this bug on www.cnczone.com/forums/deskproto).


Build date 2013-05-27   (Revision 3444) includes:
  • When opening a file that was locked by some other program DeskProto gave the wrong error ("Invalid geometry file format").
  • An inch error message (when wrapping a 2D file round a cylinder) gave dimensions in mm.
  • When directly sending NC data to a hardware port superfluous NULL-characters were sent.
  • Corrected an error when loading VRML files with large data-blocks.
  • A few development tools (code libraries) have been updated.

Build date 2013-03-08   (Revision 3210) includes:
  • Some free "single stroke" fonts were incompletely machined in a 2D operation.
  • The scrollbar in the libraries and the project tree could jump to an unwanted position.
  • Custom support blocks not always worked OK with a DeskProto set to inches.
  • Fixed a few small textual errors in the German translation.
  • Fixed a crash on 98% of the toolpath calculation for strategy circular with layers and ramping.
  • Roughing layers for strategy Radial could go far too deep when going to the next path.
  • The option "Always stay low" did not always work when a skin was present.
  • Fixed an endlessly repeating Part size error when using the wizard.
  • When changing the language the words for project, part and operation were not updated correctly.
  • 2D DXF files containing a LWpolyline with a Bulge were not read correctly.
  • The DeskProto menus contained double hotkeys (keys underlined when pressing Alt).
  • Entering a not-existing File location in the Preferences with insufficient rights caused a problem.
  • Larger font-size under the three thumb-wheels, needed to make Chinese characters readable.
  • The start screen looked weird on a 16 color display (for instance via Remote Desktop).
  • Checking one of the "before operation commands" could reset the Chaining settings.
  • The wizards used incorrect subsampling settings when choosing strategy Waterlines.
  • When running DeskProto with command line parameters the Chaining warning now is suppressed.
  • Fixed a number of small issues that could happen when Chaining.

Build date 2012-10-20   (Revision 2838) includes:
  • Milling direction "Meander" was not always disabled (grayed out) for the Block strategy.
  • Removed a crash from the wizard when running Windows XP in classic style.
  • Filled an empty error message when chaining to an invalid 2D Operation.
  • Fixed a machining level error for rotation axis machining with a 2D Operation.
  • Fixed a roughing layer error for 2D machining with a positive machining level.
  • The border value could be incorrect when using an 'Angle with X-axis' and working in inches.
  • "Restore DeskProto defaults" in the default Oper param did not reset the Before/After commands.
  • The Z-grid drawing for a 2D Operation using a rotation-axis was not correct.
  • Ambient skipping now is disabled for the strategy Contour-only.
  • Resolved a program crash on the Start-screen, when in Windows the Recent File List was disabled.
  • When removing a freeform segment, the old segment boundary was not properly deleted.
  • When cancelling part parameters including custom supports, the toolpaths were still recalculated.
  • The links to the four "other tasks" in the Start Screen did not work correctly.
  • A single stroke font was only partially machined when projecting on a 3D geometry.
  • Running a registry clean-up could cause error "Your installation of DeskProto seems to be corrupt".

Build date 2012-07-19   (Revision 2664) includes:
  • The V6 Updater did not always recognize a valid V6 installation
  • Fixed a simulation error for strategy circular, when an (unused) Angle setting was present
  • Used more clear values in the Example line for Movement (postprocessor configuration)
  • Small improvements made and spelling errors corrected in the English user-interface
  • When selecting a different machine, scrolling through the list could reset the rotation axis checkbox
  • Changing the supports in the Two-sided wizard did reset the Block thickness (Block Z) value
  • The Align option in the 2D Operation parameters did not work correctly for inch users
  • For postprocessors without Spindle commands the Before commands still could contain one
  • The command Copy Image did not always work properly
  • When opening sample project Torso-FourSides (mm and inch) the support block could not be found
  • Reducing the feed rate for high chiploads is also needed when going to the next toolpaths. This did not always work when skipping the Ambient.

Build date 2012-03-30   (Revision 2510) includes:
  • A number of small layout changes was needed for the Spanish translation.
  • At the corners of the Block strategy the cutter could remove too much material.
  • A positioning movement in the waterline strategy did not rise to higher Z level.
  • For all Roland machines the files-extension for the NC files has been changed from .ROL to .PRN
  • Fixed an error in the simulations of toolpaths at an angle with the X-axis.

Build date 2012-02-27   (Revision 2453) includes:
  • The Updater program refused to start on some Windows versions.
  • The Preview error (when adding a geometry) needed one more fix.
  • When graphically setting a support block it was impossible to go outside the part segment.
  • Translucent freeformed segments could be drawn incorrectly after scaling the part.

Build date 2012-02-20   (Revision 2428) includes:
  • Rotary toolpaths to completely move from 0 to 360 degrees sometimes were now drawn.
  • Fixed issues with error checking and warning 'balloons' in the wizards.
  • Made a few error messages more clear.
  • Despite checking "Write only if changed", a few identical A-value could be present in the NC file.
    when using Mach3 this could cause a complete rotation (bug in Mach3), possibly damaging the part.
  • The movement to step over to the next toolpath could damage the geometry in a special case.
  • Fixed a mm/inch issue in the Rotary wizard (Block dimensions, see forum thread 223).
  • In some cases the option Fill horizontal planes (waterlines) did not work for a flat cutter.
  • When adding a geometry, the Preview did not include the Part's transformations.
  • Large DXF files containing a polyface mesh could make Deskproto crash on load. Fixed.
  • 'Display translated coordinates' now also can be set in the Default parameters.
  • 'Display translated coordinates' is now checked in Bitmap operations.
  • Running scripts was possible only in the 32 bits build, now in the 64 bits build too.
    in order to achieve that the Run Script dialog needed to be redesigned (improved !).
  • When running in Trial mode not all default settings were correctly loaded.
  • Fixed a dangerous error where a positioning move ended too low (inside the model):
    now both begin and end of this move are on Free movement height (as they should be).
  • Added extra recovery for write-errors during Write NC-program file.
  • Fixed a bug voor inverse milling of the bitmap operation.
  • Various issues fixed for parallel toolpaths at an Angle with X-axis.
  • Added a missing Help issue to the German Help file.
  • For translated versions the tooltips still could be in English.
  • The Custom wizards in the translated Setups were not correct.

Build date 2011-12-12   (Revision 2291) :
  • This is the first release build of DeskProto V 6.0
  • On Dec 28 the Setup for this build has been changed: it would not run on Win XP Pro 64 bits.



Goto top

DeskProto 5.0

Below you will find the revision history of DeskProto V 5.0: all builds that have been released, with a list of changes for that build.

All DeskProto builds show a Version number (like 5.0000) and a Build date: you can find these in the About box (Help menu) of your DeskProto program.
The version number changes only in case of any changes in the user-interface: in that case also different language-files for all translated versions are needed. Bugfix releases keep the same version number: only have a different build date.

In case you need a newer build for your DeskProto V 5.0 Full edition, you can download and run the
DeskProto V5 Updater: a Setup program that will update a DeskProto V5 Full to the latest build. The updater can be used only on a PC with a complete DeskProto V 5.0 Full installed (including the dongle).

Users of the DeskProto V5 Lite edition can download and install a fresh V5 Lite trial version, and enter their old V5 unlocking code.


Build date 2011-08-22 includes:
  • Incorrect parallel toolpaths fixed, for certain angles when option "Angle with X-axis" was used.
  • Simulation could be on the wrong location when option "Angle with X-axis" used: fixed.
  • Some small font issues and other minor user-interface issues have been corrected.
  • DeskProto could crash on incorrect information in the DPJ file on NC files. Has been fixed.
  • Default bitmap operation parameters weren't updated when selecting a new default machine.
  • Bug in the JWX30 Wax Model wizard corrected, present when rotating the geometry round Y.
  • A better error message is now given when trying to open an invalid DPJ file.
  • Start commands in the NC file could be issued before the feed rate was set: corrected.
  • The status of "Also machine corners" was not stable, now it is.
  • In Vista and Win7 DeskProto didn't save in the same folder as a previous file-open (current dir).
  • Solved a crash when applying circular toolpaths in a bitmap operation.
  • Incorrect "Y too large" error on a 2D file: when wrapping it round a cylinder for rotary machining.
  • The Move buttons in Project parameters and Part parameters did not always work correctly.

Build date 2010-11-25 includes:
  • Two new Script wizards: JWX30-WaxRing and JWX30-WaxModel, for Roland JWX-30 machine.
  • For Circular strategy the Ambient area could be machined too high (see forum thread 142).
  • Toolpaths using a "Angle with X-axis" did not work for all angles (like 89 degrees). Has been fixed.
  • The button "Restore DeskProto defaults" in the defaults did not reset all parameters. Now it does.
  • When opening a faulty "DPJ file with toolpaths", the error message could keep popping up.
  • When writing the NC file for a Chain, DeskProto now shows the chained operations.
  • Using the mouse-wheel with the cursor on the border of the NC files window could cause a crash.

Build date 2010-09-02 includes:
  • Build 2010-06-04 could incorrectly detect an "invalid chain" at load project. Has been fixed.
  • DeskProto failed to detect chains with an endless loop in the chain. Now it does.
  • Creating a chain from a script or script wizard was not possible. Now it is.
  • In some cases a chained operation was included twice in the NC file. Not any more.
  • Now all Operation parameters can be set from a script wizard, including before- and after-commands.
  • Print project data did not include the setting "Always stay low".
  • Toolpaths for a 2D Operation were not updated after changing the Part segment.
  • The Edit box for the Plunge rate was too small for some fonts (visible "00" instead of "100").
  • 2D contours and 2D toolpaths were incorrect when rotation axis machining without a 3D geometry.
  • Pressing Apply and later Cancel in the Operation parameters could result in a crash later on.

Build date 2010-06-04 includes:
  • In the Bitmap settings, Translate Y did not work for rotation axis machining. Fixed.
  • Fixed some bugs in the Segment of the bitmap operation, with and without rotation axis.
  • When checking Use rotation axis, the Z-settings of any bitmap operation now are set automatically.
  • In some cases an extra groove was machined on two sides of the bitmap. Has been fixed.
  • Non-standard precision values in a rotation axis bitmap operation caused a scaling error of the bitmap.
  • When rotation axis machining a bitmap the relief in some case was not deep enough. Now it is.
  • Browsing a new 2D file when toolpaths for the old file were drawn could make DeskProto crash.
  • When opening an project, a missing STL file was not reported in case a bitmap was missing as well.
  • For users of a DeskProto V5 Full license, an Updater Setup (see above) has been introduced.
  • Translated Lite and Trial versions could not located the (translated) order form. Corrected.
  • DeskProto V5 did not correctly set the file icon for DPJ files (The "DP" icon), now it does.

Build date 2010-04-14 includes:
  • DPJ files no longer showed the DeskProto icon in Windows: fixed.
  • Inverse milling with a multiple freeform segment (more than one area) did not work. Fixed
  • Crash fixed during toolpath calculations when skipping the ambient in a very special situation.
  • After deleting a support block the toolpaths were not always recalculated. Now they are.
  • The DeskProto un-installer now also is signed (file certificate).
  • Exporting the geometry as a binary STL file did not result in a correct STL in a 64 bits Windows.
  • The DeskProto Toolbar now also has a "gripper" in a 64 bits Windows.
  • In the last build (Feb 10) a crash could occur when saving the NC file for a Chain.
  • In DeskProto's user interface several fonts were used. Now all text is in the Tahoma font.
  • Translated trial and lite versions could not find the translated order form. Fixed.
  • Save file should standard open the same directory as a previous file open: so Write NC on the same place as Open STL. This did not work in Vista and Win7: now it does

Build date 2010-02-04 includes:
  • Fixed a problem with scripts in build 2009-09-23
  • ASCII STL files written by DeskProto could not be read in Rhino. Fixed.
  • Rotation axis toolpaths were too high (above the geometry) in some cases. Corrected.
  • Operations with a different 5th axis rotation now can be chained to one combined NC file.
  • The option "Use Part segment" in a bitmap operation could result in a shifted segment. Fixed.
  • In the Add Geometry dialog a scaling of 0 was permitted. Now an error message is given.
  • When exporting the Z-Grid as STL file the model was translated, which has now been corrected.
  • When splitting an NC file due to a cutter change, DeskProto now uses self-explaining file names.
  • When copying a bitmap operation the Border settings were not copied: has been corrected.
  • The ambient area in a bitmap with 3D geometry now has the same Z as in a 3D Operation.
  • Comments in .ctr .mch en .ppr files were not kept when saving the file. Fixed.
  • In a Japanese Windows the Geometry Info dialog showed 2 columns instead of 3. This appeared to be a font-related problem: now for all texts in DeskProto the Tahoma font is used.
  • Save Project and Write NC should default to the folder from which the STL file was loaded: this no longer worked in Win Vista and Win 7. Has been corrected.
  • "Always stay low" now also works between roughing layers for strategy Contour only.
  • It was possible to close DeskProto with the Wizard dialog active, which resulted in a crash. Fixed.
  • The background color for the toolbar buttons now also is correct in Win Vista and Win 7.

Build date 2009-09-23 includes:
  • 2D toolpaths could disappear from the NC file when more lines were present on the same path.
  • When roughing with 'Always stay low', the positioning toolpath to the next layer could be too low.
  • STL files with special characters (like "%4") in the name could make DeskProto crash.
  • The Machining time estimation could be negative with waterlines combined with Always stay low.
  • After changing the machine the warning about resetting all speeds now is given only once.
  • When renaming lines in the tree, sometimes the characters c, v, x and z could not be used.
  • The simulation in DeskProto was incorrect for negative skin values (roughing).
  • DeskProto needs to disable the Aero look in Win Vista (see Forum topic 23): this now is done by Dp.exe instead of by the Setup. This new method also works for 64 bits Vista.
  • Automatic speed settings in a Cutter definition still were not correctly read from the CTR file.

Build date 2009-08-10 includes:
  • "Skip total ambient" for rotation toolpaths skipped an incorrect area (Forum topic 96). Now fixed.
  • Circular/radial toolpaths could damage the part when the operation segment was smaller than the part.
  • It was no longer possible to delete Start Commands and End commands in the postprocessor. Fixed.
  • The DP Lite Bitmap Settings showed the picture for "Project bitmap". No such option, so removed.
  • Drawing the rendered Z-grid of a rotation axis path crashed for certain segment angles. Fixed.
  • Fixed an incorrect error text ("created by newer version") when reading a corrupt DPJ file.
  • Corrected some minor textual errors and inconsistencies.
  • The N-sided wizard now creates a toolpath that both starts with and ends with a A=0 command.
  • Protect vertical surf (roughing) did not work correctly when stepsize not equal to path distance.
  • Fixed a crash in the Machine library when the opened project included a 2D operation.
  • In the Cutter definition dialog grayed-out edit fields could contain an incorrect value. Fixed.
  • It was impossible to rename the first default part and operation (or rather to store the change).

Build date 2009-06-19 includes:
  • "Always stay low" used with waterlines could result in positioning moves through the part. Fixed
  • This same combination could result in positioning moves below the current waterline. Fixed
  • In some cases (vertical surfaces) the cutter would move too low when machining in layers: fixed
  • An "endless loop" was possible in the waterline calculations, making DeskProto hang. Fixed.
  • Crash when calculating toolpaths if no toolpaths are possible. Now a warning will be shown.
  • DeskProto V 5.0 refused to read DPJ files written bij V 5.1 or newer. Now a warning will be shown.
  • "Protect vertical surfaces" did not always work when moving to a next toolpath. Fixed.
  • In a project with only one custom support bridge it was not possible to add a second. Fixed.
  • Copying and pasting Names in the Tree window was not possible, now it is.
  • The postprocessor dialog only read four digits behind the decimal point. Has been set to six.
  • "Calculate Z-Grids" resulted in an incorrect warning ("No valid toolpaths"). Fixed.
  • On some PCs the geometry was rendered in grey only. The color has been restored in these cases.
  • Automatic speed settings in a Cutter definition were no longer read from the CTR file: corrected.
  • The first point of a waterline toolpath could be too high, depending on previous calculations. Fixed.
  • For inverse milling an area that needed to be at minimum Z could end up at maximum Z. Corrected.

Build date 2009-04-21 includes:
  • The wizards did not copy precision values from the default operation parameters: corrected.
  • Crash when using "Restore DeskProto defaults" in the default Bitmap operation parameters: fixed.
  • Incorrect error "bitmap missing" when setting the default bitmap operation parameters: removed.
  • Deadlock situation or crash removed when running some scripts.
  • Before/After commands could no longer be removed once set: corrected.

Build date 2009-03-25 includes:
  • Setup error in 32 bits Vista ("cannot access 64 bit registry") for the builds of Feb 11 and March 11.
  • Start/End settings dialog in inches (see above) now also in translated versions.
  • It was not possible to set custom bitmap dimensions in translated versions of DeskProto: fixed.

Build date 2009-03-11 includes:
  • Much smaller files for program and for Setup after replacing BMP files by PNG files.
  • The 123WaxModel wizard now explicitly disables the rotation axis to overrule any default.
  • The Start/End settings dialog did not switch to inches when DeskProto was set to inches: fixed.

Build date 2009-02-11 includes:
  • Crash when changing the language with an open unsaved project: fixed.
  • A user-defined Before-command appeared twice in the NC file: fixed.
  • Incorrect size-error on OK in the Part parameters for rotation axis machining: fixed.
  • In very long trees an incorrect part of the tree could be shown: corrected.
  • Some fields in the Edit postprocessor dialog were wrongly greyed out: fixed.
  • The Script wizards could not be translated: now different files are opened.
  • Scaling error when reading EPS and AI files: scale was 2.84: now is 2.8346462.
  • When copying an operation not all settings were copied: fixed.
  • Error when using "^\V" in the postprocessor definition, for a Rapid using Feedrate: fixed.
  • Incorrect positioning moves with "always stay low" for circular strategy: fixed.
  • Cutters with "multiple diameter" checked were not correctly read (only in build Dec 17): fixed.
  • Crash on "Print project data" for bitmap operations: fixed.
  • Missing parts in 2D toolpaths for DXF files with many very small line segments: fixed.
  • Added commands Y=0 (before) and A=0 (after) to last Part of 123WaxRing wizard.
  • Dangerous error toolpaths when "Always stay low" combined with "Skip total ambient": corrected.
  • Always stay low did not yet work for ALL positioning moves: improved.
  • Serious errors when using Scripts in DP Lite: scripting in Lite now disabled.
  • Error when reading AI files containing offset curves: fixed.
  • Bug for the Custom DPI edit box in the Bitmap settings: corrected.
  • Error in the rotation commands when using the N-sided wizard: fixed.
  • Translation value could change when "display translated coordinates" was used for the segment: fixed.
  • Changed the default reply on "Are you sure" questions when deleting from No to Yes.
  • Bug corrected when automatically deleting superfluous points on a long straight toolpath.

Build date 2008-12-17 includes:
  • Drivers for some Italian machines were missing in the Setup: added.
  • Incorrect view when setting the Bottom level in wizards N-sided and Rotation: now correct.
  • Skip Backfaces no longer worked: functionality restored.
  • Crash when editing Start/End commands: fixed.
  • Crash when drawing the Z-grid for a projected 2D operation: fixed.
  • Crash when importing Registry files (Tools -> Import): fixed.
  • Great improvement in speed when reading large DPJ files.
  • Zooming and rotating is more intuitive when zoomed in to a very small detail.
  • The mouse-wheel now can also be used when graphically setting segments and support blocks.
  • Project 2D contour on 3D geometry now also works for inverse milling.

Build date 2008-09-30 :
  • This is the first release build of DeskProto V 5.0

Goto top

For more history see the timeline on Facebook.