to DeskProto home page
Contact  
looking glass icon
to DeskProto Facebook page
to DeskProto Google Plus page
to DeskProto Youtube page

Forum menu:

DeskProto user forum

Forum: communicate with other users.


Forum home page main
Forum:
Thread:
Vista
You’re logged in as:guest
Online users:0
Online guests:34
 

page 1 of 2


Chris
2007-03-14
13:40 CET
Any one running Vista with DP
and is there any bugs doing so. ?
I need to get new pc and xp is getting hard to get
in my location
Thanks Chris

Lex
2007-03-15
19:49 CET
Hi Chris,

There have been a few reports of the trial version not giving a 30 days trial period on Windows Vista . So far no reports about the licensed version.
We will get a Vista development PC next week, and I will mention on the forum what we will find out.

Lex.

Lex
2007-04-10
13:58 CEST
Well, it took some time to get our testing PC (Windows Vista Home Premium), and even some more time to understand all that goes wrong when installing DeskProto on Vista. We have not yet finished,: we hope to be able to make a "Vista-workable" build later this month.

Issues are:

- many user-rights related issues: DeskProto needs permission to do things like registering a DLL or save Trial status information. For the bugfix version we want to cover all issues with one combined Vista Warning when starting DeskProto, where the user needs to give permission.
The warning still will be that "An undentified program wants to access your computer". It might be that later we need to apply for a "Certificate" from Microsoft to prevent such message (for DeskProto V 5).

- The DeskProto Help does not work in Vista. This will be solved for V 5, not for V 4.1

- We received a report that unzipping Setup.exe does not work in Vista, have not been able to reproduce it though.

- The Open-GL drawing does not work properly on our test PC (nothing is visible, the drawing only flashes over the screen when dynamically rotating).
More in general it appears that Open-GL graphic display drivers under Vista still contain many errors. The advise is to wait: Vista apparently is not yet ready to be used for CAD/CAM aplications. The same advise is given by major CAD vendors: just today I read that even the brand new Autocad Inventor 2008 will not work with Vista.

- We are still working on a crash (DeskProto freezes) when starting DeskProto in Vista, that sometime occurs, and sometimes not. When that is fixed we will come with a new DeskProto 4.1 build.

This new build will work with Vista, but not yet perfect. So our advise still is to wait with Vista. We hope that when DeskProto V5 is released (later this year) the problems will have been solved.

Lex.

Lex
2007-04-17
14:48 CEST
We have just uploaded new builds of DeskProto V 4.1:
Full (the bugfix update), Trial and Lite (the standard downloads from the website). These new builds are compatible with Windows Vista - as far as possible.

Issues that have been solved:
- Trial and Lite indeed offer a 30 days trial period
- A crash when starting DeskProto has been fixed.

Limitations still are:
- a Vista warning when starting the program
- the Help does not work
- you may expect graphics problems as drivers still need to be debugged by the Graphics card manufacturers.
So we advise to wait with Vista until DeskProto V 5.0 will be ready later this year (no date planned yet).

Lex.

Lex
2007-04-18
16:25 CEST

This is the warning that Windows Vista will show each time when DeskProto 4.1 is started. In order to run DeskProto you need to choose Allow.

Lex
2007-05-08
21:05 CEST
On April 10th, I mentioned an OpenGL problem on our Vista test PC. We have been able to solve that problem simply by turning OFF the new Vista AERO look. This was suggested by some OpenGL guru in an interview. So we did not even need to wait for new drivers after all.

You can find this setting by right-clicking on the screen, then choosing "Personalize" (what used to be called Properties in XP) and then "Window Color and Appearance". Changing the Color scheme from "Windows aero" to "WIndows Vista Basic" solved our problem.

So the advise is to switch Aero off when you use CAD/CAM software based on OpenGL.

Lex.

Lex
2007-05-13
11:30 CEST
Some more information:

In my previous entry I explained how to turn off the Aero look of Windows Vista, needed to make OpenGL run properly. It appears to be also possible to turn off Aero for just one application, so for DeskProto. Source of this information is the Rhino website.

Here is what to do:
1) Right-click on the DeskProto icon on your desktop and select "Properties".
2) Click on the "Compatibility" tab.
3) Check the option "Run this program in compatibility mode for:" and then select "Windows XP (Service Pack 2)".
4) Check these 2 options:
[X] Disable visual themes
[X] Disable desktop composition.

It also is possible to use the DeskProto 4.1 Help in WIndows Vista, by downloading the WinHelp upgrade for Vista from the Microsoft website.

Lex.

Lex
2008-08-12
12:04 CEST
In addition: we just found out that in Vista it may also be needed to turn the Vista UAC (User Account Control) OFF
(Start -> Control Panel -> User Accounts).

This may be needed to allow changes in the DeskProto libraries, for more information see the thread on that issue: Topic 69

Lex
2008-11-25
10:42 CET
All the above entries were meant for DeskProto V 4.1 or older. DeskProto V 5.0 automatically makes the correct setting during Setup:
- Disable desktop composition is checked
- DeskProto is started with administrative privileges.

Checking the settings "XP compatibility mode" and "Disable visual themes" that are mentioned earlier in this thread is not needed.

Lex
2008-12-16
13:55 CET
The story continues:
In the 64 bits version of Windows Vista it is not possible to check any compatibility settings for 64 bits applications. So also not the "Disable desktop composition" setting.

So for users of a 64 bits Vista who have run the Experience Index the 64 bits DeskProto will not function correctly. The only solution for this special situtation that we now have is to completely disable the Aero look on the PC:
System Properties -> Advanced -> Performance Options -> uncheck Enable Desktop composition.



page 1 of 2